Loop - The Distress Call

"Mayday! Mayday! This is the FCV Raptora requesting immediate assistance!"Loop is an interactive story in which every little choices change radically the story. Your behavior and your bonds you build with the character will deeply affect the outcomes.You receive a distress signal from Ensign Althea Young: her ship is malfunctioning and the rest of the crew is compromised by a mysterious sickness. Youre the only person who can help.As Althea struggles to understand what is happening, she will contact you throughout the day through notifications by sending you her findings and fears.Each choice is important, and your behavior is decisive: the smallest interaction can have fatal consequences. Make your own decisions. Choose how you want to assist Altheas efforts to save her ship and crewmates and discover the numerous endings.The case cant be solved without you. Listen to Althea. YOU can help.FEATURESENTHRALLING SCIENCE FICTION STORYAuthor Estee Lee-Mountel offers you an immersive and suspenseful storyline that unfolds in real-time based on dialogues. A very unique science fiction thriller game .filled with suspense.BUILD A RELATIONSHIPWork with and develop a bond with the ships remaining crewmember, Ensign Althea Young. Your behavior and your relationship are critical to the success of the mission.CHOOSE YOUR STORYEach decision has the potential to set off a chain reaction crucial to the investigation.Multiple endings, and epilogues that detail the ripple effect of your findings.INVESTIGATEUncover and compile clues to aid your investigation through dialogue with Althea. Your choices, findings, and judgment are crucial to your collective understanding of the situation and the games outcome.PLAY IN REAL TIMEAlthea sends you messages in real-time to keep you updated on her situation and findings. You will receive notifications on your device from her; you can answer right away or whenever you are free.Loop is only available in english.
Price USD 1.99
License Purchase
Version 1.03
Operating System iOS
System Requirements Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.