Darkness Rises

Darkness crawls throughout the land and within it lurks a horde of ferocious demons ready to breach our gates. The path ahead will be grueling, but you must persevere and descend into hell itself to destroy this evil before it ravages our world.Darkness Rises is a revolutionary Action RPG that blends gorgeous graphics, innovative gameplay, and intense boss battles, all within the palm of your hands.From the earth-shattering Berserker to the magic-wielding Wizard - choose from a number of classes that fits your playstyle. Decimate fearsome monsters with a flurry of powerful skills or unleash them in the arena against other players.Conquer the darkness before it conquers you.Key Features:BOSS FIGHTSEngage in challenging boss battles that will put your skills to the test as you venture deeper into the abyssAWE-INSPIRING GRAPHICSExperience stunning visuals that will truly immerse you into the world of Darkness RisesGROUNDBREAKING GAMEPLAYUse the Soul Link ability to seize control of monsters and turn your enemies against themselvesEPIC DUNGEON RAIDSGather your allies and guildmates to explore menacing dungeons and discover rare lootFollow us on official communities to get latest news and updates!Facebook: www.facebook.com/NexonDarknessRisesPLUG: www.plug.game/darknessrises/Terms of Service: http://m.nexon.com/terms/304Privacy Policy: http://m.nexon.com/terms/305Recommended Specifications: iPhone 6S or higher / iOS 9.0 or higherMinimum Specifications: iPhone 5S / iOS 11 (For iPhone 6S or higher: iOS 9.0)¦ App Permissions InformationIn order to provide the below services, we are requesting certain permissions.[Optional Permission]- Optional permission does not affect gameplay.Camera: Taking screenshots to help with customer service inquiriesPhotos: Attaching screenshots for customer service[Permission Management]Settings > Privacy > Select the permissionThis app offers in-app purchases. You can disable this feature by adjusting your device settings.
License Free
Version 1.1.1
Operating System iOS
System Requirements Requires iOS 9.0 or later. Compatible with iPhone 5s, iPhone 6, iPhone 6 Plus, iPhone 6s, iPhone 6s Plus, iPhone SE, iPhone 7, iPhone 7 Plus, iPhone 8.