Crazy ice cream truck driver

Beep beep!!Hallo ice cream drive lovers! Welcome to the crazy ice cream world. Do you like fast van games and duty driver games? Crazy ice cream truck driver games for free is classic highway racing app full of awesome ice cream truck delivery games, cool ice cream truck sound effects and ice cream car engine noises. If youre a fan of big ice cream truck driving games or any kind of madness racing, then youre going to fall in love with kids ice cream adventure game.Ice cream delivery games including ice cream cart, ice cream truck music and ice cream truck song. So when you download this selling ice cream racing game your little ice cream seller boy will get cool ice cream land with awesome ice cream crazy truck.Ice cream truck games for kids features:Banana ice cream truck simulator with trafficToddler ice cream runVanilla ice cream shop game for childrenBig ice cream truck sound child games for 4 year oldsIce cream parlorCandy truck duty driverCatching ice cream cupcakes Crazy ice cream busCollect coco ice cream cookiesIce cream truck sound effects and ice cream truck noises for babiesIce cream truck kids vehicles gameplayLittle road fighter boy touch small ice cream van nitro button to accelerate the speed to avoid fire trucks, police car truck, ambulance truck traffic racer and tank. Tilt to steer crazy ice cream kids car away from other vehicles and collect chocolate ice cream cone cupcakes as much as you can in my ice cream job. Little seller child also gets extra ice cream drop points if he catch the included checkpoints along highway madness. Ice cream rush games for children are quite interesting, but it is not so easy to play.Toddler crazy ice cream truck driver games for free will be updated constantly.Free ice cream truck games work perfectly on tablets and mobile phones. Have a great ice cream time! If your road fire fighter like this ice cream app please press +1 button.Content rating: Everyone
PriceCAD0
LicenseFree
File Size5.77 MB
Version1.0
Operating System Android
System RequirementsCompatible with 2.3.3 and above.