OWC Mercury Elite FireWire 800 Firmware

After sporadic reports of data loss and corruption with FireWire 800 devices operating with the new Mac OS X 10.3 "Panther" operating system, Apple Computer made an official press release to indicate this problem has been traced to Oxford Semiconductor's 922 Firmware used by nearly all FireWire 800 devices, including the OWC Mercury Elite 800 series. No OWC Mercury Elite FireWire 800 product has a firmware version lower than v1.02, but it is our recommendation that you follow the enclosed link to our v1.05 firmware update page. There you will find the the instructions and software which will enable you to upgrade your OWC Mercury Elite 800 drive to the latest v1.05 firmware version. Apple Computer, Inc. is working with Oxford Semiconductor to fix this problem within OS X 10.3 Panther in a way that would not require the later Oxford 922 firmware version, but we here at OWC are happy to provide the firmware update information as an immediate and total solution regardless of what Apple and Oxford may do in the future. Please make note that this issue has only affected a small number of customers but we take this issue very seriously and highly recommend that all customers update their drive's firmware revision.
PriceUSD0
LicensePurchase
File Size1003.02 kB
Version1.0
Operating System Macintosh Mac OS X 10.2 Mac OS X 10.3
System RequirementsMac OS X 10.2.8 or 10.3