Barometer++ Widget

The first iOS 8 widget for iPhone 6 and iPhone 6 Plus your barometer is one wish down!Thanks for your replyONLY FOR IPHONE 6 AND 6 PLUS!!!!!
Price USD 0.99
License Purchase
File Size 640.7 kB
Version 1.0
Operating System iOS
System Requirements Compatible with: ipad2wifi, ipad2wifi, ipad23g, ipad23g, iphone4s, iphone4s, ipadthirdgen, ipadthirdgen, ipadthirdgen4g, ipadthirdgen4g, iphone5, iphone5, ipodtouchfifthgen, ipodtouchfifthgen, ipadfourthgen, ipadfourthgen, ipadfourthgen4g, ipadfourthgen4g, ipadmini, ipadmini, ipadmini4g, ipadmini4g