This app requires a Redline FlexTalk Push-to-Talk server in order to function.Note: This app may use your location even when it isnt open, which can decrease device battery life.
License Free
Version 14.4
Operating System iOS
System Requirements Requires iOS 10.0 or later. Compatible with iPhone, iPad, and iPod touch.