Record360 is the property inspection and asset condition reporting app for your Android device. Whether you are renting, sharing or simply documenting, Record360 provides high quality, time-stamped, geo-tagged records of property at time of exchange. Record360 gives you peace of mind No more damage disputes, and gone are the days when you might be on the hook for existing damage!So rest assured. Weve got you covered.Device Support: Record360 is currently being tailored to specific businesses and their devices, and development for the wider universe of Android is ongoing. Record360 is currently available for Samsung Tab 4, Samsung Tab Pro, Google Nexus Tablet, and most Android 4.4+ devices, with Samsung Galaxy S and Note support coming soon. Please advise support@record360.com if you encounter any issues with your specific device.Record360 is the essential tool of the sharing economy. FEATURES: Tap and upload: Easily and intuitively capture property condition and notations Instantaneous, indisputable evidence, with real-time visibility from anywhere on any device High-quality documentation and reporting via Record360s secure and independent platform Data does not reside on device or clog your hard drive Widely applicable across a broad range of use cases and scenariosFor Businesses, Record360 is fully customizable for a variety of enterprise applications and reporting needs in different industries. Advanced workflows, custom checklists, and full third-party integration are available. The app is currently used in numerous verticals, including: Vehicle Rental Companies; Body Shops; Auto Dealerships; Equipment Rental Companies; Transportation Companies; Moving Companies; Towing Companies; Shipping/Logistics; Property Management; and Property Development and Construction. Contact sales@record360.com for more details.Recent changes:- Added Instruction Overlay Feature to Media Capture- Bug FixesContent rating: Low Maturity
PriceCAD0
LicenseFree
File Size4.73 MB
Version1.01
Operating System Android
System RequirementsCompatible with 2.3.3 and above.