Euro-taxi Era (Lutsk)

App for ordering taxi in Lutsk
LicenseFree
Operating System iOS
System RequirementsRequires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.