DeliverMe TT Driver

DeliverMe TT Lt is a Trinidad networking company formed in 2019 that uses technology to offer transportation services through cash and cashless payment systems via mobile apps. We use GPS technology to offer different types of transportation services affordably, efficiently and safely. We connect people, packages or things from doorstep to doorstep anywhere within Trinidad and Tobago DELIVERME TT APP - TOGETHER WE STAY CONNECTEDWHY BECOME A DELIVERME TT DRIVERDeliverMe TT Driver app offer additional services (taxi, delivery, and moving) for you to earn more. We connect people, packages or things from doorstep to doorstep anywhere within Trinidad and Tobago.EARNING THE SMARTER WAYWe are more than a Taxi App.We offer reward and recognition schemesEarn Tips on ridesYour time is your money.Become debt freeBe your own boss. Work your own flexible hoursREQUIREMENTSHave a Smartphone (Running Android 7.0 or IOS 11) to run DeliverMe TT Driver AppActive Data Plan from a telecommunication service provider to receive uers's request. A full time driver can absorb at least 2GB per month.A vehicle not older than 10 yearCustomer focused and customer centricDownload the DeliverMe TT Driver App and register filling in your personal details and uploading the specified documents. Upon completion we will be notified and will arrange an interview with you. It's that simpleOnce on board we will provide all the additional support through our website at www.delivermett.com and other communication channelsFEATURESDeliverMe TT Driver App is very simple and transparent to use. It offers features where:Driver can pick the job they want to do taxi. delivery or taxi and deliveryDrivers can easily keep track of their daily and historical earningsChat with support when necessaryCall emergency number if neededFollow us on the following social handlesFacebook: DeliverMe TTInstagram: delivermettTwitter: delivermettWebsite: delivermett.comEmail: info@delivermett.com
Price USD 0
License Free
Version 4.2.2
Operating System Android
System Requirements Requires Android 4.2 and up