Lift-It

Validate your lifting lugs design to AISC 13th Edition and ASME BTH-1 standards, or enter the load you want to lift and the App will design the proper lifting lug for you.This App also helps you select the Proper Shackle for the load;Sample Lugs Module can propose Lugs Shapes for a load up to 120,000 Lbs. per LugCalculation for simple and complicated lug shapes to multiple factors of safety includes:- Various Geometry Checks- Tensile Strength as per AISC and ASME- Bearing Capacity as per AISC and ASME- Tearing Tension as per AISC- Shear Rupture Capacity as per AISC- Gross Section Yielding per as AISC- Single Plane Fracture Strength as per ASME- Double Plane Fracture Strength as per ASME- Allowable loading- Required Weld StrengthNote: This App Features Auto-Renewable Subscriptions allowing you to use the app after the trial period is over. for more details check the subscriptions page within the App.Applicable to All subscriptions offered (Gold & Silver Membership):1 - Seven day free trial, Free of charge; no commitment, cancel anytime2 - All Subscriptions costs is shown in your local store currency;3- Length of subscriptions available are: one month for Silver Membership or one year for Gold Membership3 - All payments will be charged to your iTunes Account at confirmation of purchase4 - All subscriptions automatically renews unless auto-renew is turned off at least 24-hours before the end of the current period5 - Your Account will be charged for renewal within 24-hours prior to the end of the current period, and the cost of renewal will be the same as displayed in each membership section6 - You can manage the Subscriptions or turn off auto-renewal by going to your Account Settings after purchase7 - Any unused portion of a free trial period, if offered, will be forfeited when you purchase a subscription to the publication8 - Links to our Privacy Policy and Terms of Use:http://spiderdaq.com/privacy-policyhttp://spiderdaq.com/Terms
Price USD 0
License Free
Version 1.01
Operating System iOS
System Requirements Requires iOS 10.3 or later. Compatible with iPhone, iPad, and iPod touch.