App will keep you up to date in St Louis County District 2, should I be elected in November. Contact info always readily available.
License Free
Version 2.5
Operating System iOS
System Requirements Requires iOS 7.0 or later. Compatible with iPhone, iPad, and iPod touch.