Support for the Nikon D2X and D2Hs has been added. With upgrade of WT-1 firmware to version 1.1, the WT-1 can be used with the Nikon D2X and D2Hs cameras. This version is the first release on CNET
File Size165.44 kB
Operating System Macintosh Mac OS X 10.3 Mac OS X 10.1 Mac OS X 10.2
System RequirementsMac OS X 10.1/10.2/10.3/10.3.9


You have been successfully signed up. To sign up for more newsletters or to manage your account, visit the Newsletter Subscription Center.
See All
See All