dotConnect for PostgreSQL

dotConnect for PostgreSQL is an enhanced data provider built over ADO.NET architecture and a development framework with a number of innovative technologies. With state of the art ORM solutions such as Entity Framework and LINQ to SQL, it introduces new approaches for designing applications and boosts productivity of database application development. Key Features: * Database Application Development Extensions dotConnect for PostgreSQL has a rich set of design time tools that leverage the development process greatly. Particularly, there are convenient component editors, wizards and managers, toolset for live data binding, DDEX, a and much more. * PostgreSQL Advanced Features Support dotConnect for PostgreSQL allows developers to harness full capabilities of the PostgreSQL server. dotConnect for PostgreSQL supports such PostgreSQL-specific features as secure SSL connections, PostgreSQL notifications, PostgreSQL bulk data loading and others. * Optimized Code dotConnect for PostgreSQL assemblies are implemented using optimized code and advanced data access algorithms. * ORM Support dotConnect for PostgreSQL offers enhanced ORM support with a bundled visual designer for ORM models - Entity Developer. It offers you advanced support for Model-First and Database-First design approaches and flexible T4 template-based code generation for the model. dotConnect for PostgreSQL supports Entity Framework v1, v4, and v5, NHibernate, and LinqConnect (formerly known as LINQ to PostgreSQL) - Devart's own ORM solution, closely compatible to Microsoft LINQ to SQL. Entity Framework v4.1 features - Code First and DbContext API are supported in a new DbContext template with fluent mapping generation. dotConnect for PostgreSQL now supports Entity Framework Spatials.
Price $99.95
License Free to try
File Size 56.11 MB
Version 6.80
Operating System Windows Windows NT Windows 98 Windows Me Windows 2000 Windows XP Windows 2003 Windows Vista Windows 7
System Requirements Microsoft .NET Framework 2.0, 3.0, 3.5, 4.0, 4.5, Microsoft .NET Compact Framework 2.0 and above